Wednesday, November 28, 2007

Chase Jarvis - a fortune in gear bags?

I was checking out this video on Chase Jarvis' site that details how he and his crew pack their gear for easy, accurate, and safe deployment. This is the long version, you can see the short, YouTube version on Chase's site, and over on the Strobist post about the video.

As I'm watching this video, I can't help but wonder at the small fortune in Lowepro and Pelican cases this man has amassed!!! I mean, I knew my wife had a bag fetish, but damn!

Updated 1D MkIII Service Bulletin - repairs start 12/3/07!

Canon has released an updated service bulletin for the 1D MkIII sub-mirror adjustment issue. Looks like they'll start taking cameras next week (12/3). If you missed it, the original bulletin describes the problem as Canon understands it.

In the meantime, 1.1.3 appears to be successful for several folks - my own very brief, subjective testing last evening suggests that low light AF is definitely a lot snappier, and seemingly accurate. It will be interesting to see if Rob Galbraith releases anything about it today... ;)

Tuesday, November 27, 2007

1D MkIII Firmware 1.1.3 released

Curiously, though - it does not mention the auto-focus issue mentioned in my previous post on MkIII announcements. Rob Galbraith also makes mention the firmware update, but offers no thoughts on whether it, in and of itself, makes any improvements... Hmmm....

In the meantime, we await the start of the sub-mirror repair process - and anticipate that Galbraith's forth-coming next update to his 1D MkIII autofocus issues report might shed some light on whether we truly get full relief or not... I'm hoping we do, cause this camera is otherwise fantabulous ;)

Time will tell....

Wednesday, November 21, 2007

Canon 1D MkIII woes - soon to end?

Earlier in the week, I sent a private message to Canon's Chuck Westfall via the ProPhotoHome forum. I was concerned about the availability of the much discussed and anticipated 1.1.1 firmware release. For the record, my MkIII is not performing extremely poorly, like some of the examples out there. But, there's reportedly a fix in the proposed 1.1.1 that addresses an issue I am seeing, where autofocus simply stops working - you press the AF-ON button, or whatever, and nothing happens. Wait a bit, or fiddle with other controls, and it starts working again - I haven't yet established a clear pattern on how to resolve it.

Chuck responded back in an understandably cryptic fashion:

The question you're asking here will be answered in our next web announcement, which is scheduled to go live next week. I can't release the details yet, but I think you'll be pleased.

So, make of this what you will - perhaps in the near future we'll be hearing of not only the start of the sub-mirror repair actions, but also some firmware updates as well??? Either way, sounds like progress, to me... Many thanks to Chuck for taking the time to respond to my inquiry!